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Chapter 1
Introduction
This section includes the following topics:
■ Utilities Included with the System

■

Starting the Utilities

Utilities Included with the System
This guide describes the following software utilities provided with the SLS system:
■ Remote Notification, which can tell
■ Build Report, which extracts selected
you when builds finish or problems
information from the build packet and
occur, by pager or e-mail
the states.blog file in a spreadsheet
format
■ Remote Status, which checks the
status of the SLS system from a
remote system

■

Gettimes, which summarizes
important time data from a build’s
states.blog file

■

The Scale-Offset II and Runtracker
workbooks, which generate and track
scale and offset data

■

STL Optimization utility, which
reorganizes STL files so that they
load and display faster

Gettimes, Build Report, Scale-Offset II, Runtracker, and STL Optimization Utility can
be used immediately upon installation. Remote Notification and Remote Status
require some setup and configuration to be useful. The sections that follow describe
each utility in more detail.
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Starting the Utilities
All of the utilities except Gettimes, Scale-Offset II, and Runtracker can be found on
your Windows Start menu. To use the menu, select Start→ Programs→ Dtm. The
Dtm menu appears. Select a utility from the menu to start it.
To start the Gettimes utility, use Windows Explorer to display the c:\dtm\bin directory
and find the Gettimes.exe file. Double-click the filename. There are also several
command-line options you can use with Gettimes; to issue command-line options,
you must run Gettimes from an MS-DOS window. See “Gettimes” on page 40 for
more information.
For information on starting Scale-Offset II and Runtracker workbooks, see “How to
Use the Workbooks” on page 60.

Chapter 2
Remote Notification
The Remote Notification utility allows you to notify people via pager or e-mail when
certain events occur during use of the SLS system. You can also have events trigger
application programs or operating system commands.
The Remote Notification utility runs on the SLS system. It requires access to a
modem, either locally or through a network.
This section includes the following topics:
■ Starting the Remote Notification
■ Setting Up Remote Notification
Utility
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Starting the Remote Notification Utility
To start the Remote Notification utility, select Start→ Dtm→ Remote Notify. The
RemoteNotify window appears.

Toolbar
Columns for
consequences

List of
event
types

Shows
whether the
utility is
currently
active

Figure 1. RemoteNotify Window

Activating and Deactivating the Utility
When you start the application, it is active, meaning it will send notifications. If you
want to temporarily disable notification while the application is running (for example,
to make changes to notification options), select File→ Deactivate. The words “Not
Active” appear in the status bar at the bottom of the window. To activate the utility
again, select File→ Activate.
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Setting Up Remote Notification
Before you can use the Remote Notification utility, you must perform several setup
tasks. These include selecting events that you want to be notified of, and entering the
pager numbers, e-mail addresses, and application programs that you want the
program to use when an event occurs.

Settings and Data Files
The Remote Notification utility stores two kinds of information: settings files and data
files. Settings files store your choices of what events should cause someone to be
notified and how they should be notified. They use the .cfg extension. Data files store
names, e-mail addresses, and codes. They use the .dat extension. Both types of files
are stored in the c:\dtm\config\RemoteNotify directory.
You can have several settings files, but each accesses the same Address Book for email addresses and Code Book for pager codes.
After you start entering setup information, you should save a settings file by selecting
File→ Save or clicking .
When you initially start the utility, the settings file is untitled.
You can load an existing settings file by selecting File→ Open or clicking .

✏ The Remote Notification utility keeps a list of recently-used settings files on the File menu.
Events and Consequences
Remote Notification is based on events and consequences. Consequences are the
actions the Remote Notification utility takes when a specific type of event occurs.
The events that can trigger consequences include:
■

Alarms, warnings, and advisories: You can select different consequences for each
of these three types of messages.
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■

Inert reached: The system has inerted the process chamber.

■

Stages and completion: You can select consequences for the system’s entry into
each of the three build stages (warm-up, cool-down, and build) as well as for build
completion.

✏ Remote Notification will send a build complete message whether the build ends normally or
due to a problem.

■

Z heights reached: You can select consequences for the system to apply when the
build reaches specific Z heights. See “Setting Up Z-Height Triggers” on page 28
for more information.

For each type of event, you can select the following consequences:
■ The utility pages one or more persons.
■

The utility sends e-mail to one or more persons.

■

The utility runs one or more programs.

■

Any combination of the above.

Selecting Consequences
The RemoteNotify window contains a table with a row for each type of event. In each
row, you can select a check box for each type of consequence. For example, the
following figure shows the RemoteNotify window with Pager and Mail consequences
selected for Alarm events:
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Check boxes
indicate that
Alarm events
will trigger
Pager and Mail
consequences

Figure 2. RemoteNotify Window with Consequences Selected

In addition to selecting the check boxes, you must set up the details of each
consequence as described in the sections that follow.

Printing Settings
You can print the table of settings and consequences shown in the RemoteNotify
window by selecting File→ Print or clicking .
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Figure 3. Sample Settings Printout

Setting Up Pager Notification
To use pager notification, you must:
1. Set up the modem server.
2. Set up the pager.
3. Create a phone book
4. Create a code book.
5. Create pager lists for each event that should result in someone being paged.
The sections that follow describe each of these steps in detail.

Setting Up the Modem Server
Before you can use the pager notification features of the Remote Notification utility,
you must install and run the Modem Server software on a computer with a modem.
The modem server software is included on the SLS systems software CD. You can
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use a modem connected to the SLS system directly, or a network modem, as shown
in Figure 6.
Installing the Modem Server

✏ The Modem Server software is installed on all SLS systems. If you intend to use a network
modem rather than a modem installed in the SLS system computer, the Modem Server
software must be installed on the computer that has the network modem.

To install the modem server, perform a standard SLS system software installation as
described in “Installing or Uninstalling the Software” in Chapter 3 of your Reference
Guide. The modem server is automatically installed as part of the system.
Running the Modem Server
After you complete the installation, run the ModemServer.exe program located in
c:\dtm\bin. The DTM Modem Server window appears:
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Click this
button to
select a
modem

Figure 4. DTM Modem Server Window

Select a modem by clicking the Select Modem button and make a selection from the
drop-down list in the dialog box that appears.
The DTM Modem Server application must be running before you start the Remote
Notification application. It must remain running at all times while the Remote
Notification application is running.

✏ After you run the Modem Server, find out the IP address of the computer with the modem so
that you can use it in setting up the pager. Determine if your network uses dynamic
addressing, and if it does, ask your system administrator to set a static address for the
computer with the modem.
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Setting Up the Pager
To set up the pager, start Remote Notification and select Edit→ Pager Setup. The
Pager Setup dialog box appears. Enter appropriate values in the two text boxes.

Enter the IP
address of a
computer that
has a modem
and is running

Use the
default value

Figure 5. Pager Setup Dialog Box

Modem IP Address is the internet protocol (IP) address of a computer with a
modem. This computer must be running the DTM Modem Server application as
described in “Setting Up the Modem Server” on page 8.

✏ Avoid using the IP address 192.88.202.1, which is reserved by the SLS system for use in
communicating with its internal scanner computer.
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Network modem
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Use IP address of the computer
with the modem in the Pager
Setup dialog box

Network
Modem

Local modem
Use the self-referential IP address
127.0.0.1 in the Pager Setup dialog box

Modem connected
directly to the
application computer
Figure 6. Possible Modem Configurations and IP Addresses

Socket Port is the address of the modem interface application that handles paging
requests from the Remote Notification utility.

✏ Use the default Socket Port number unless instructed to change it by 3D Systems.
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Creating a Phone Book
A phone book provides a list of phone numbers that you can page from the Remote
Notification utility. To create a phone book for your company:
1. Select Edit→ Phone Book.
The Edit Phone Book dialog box appears.
Click the Add
button to display a
dialog box where
you can add
names and pager
numbers

Select a name,
then click the
Edit button to
change a name
or pager
number
Figure 7. Edit Phone Book Dialog Box

2. For each phone number you want to add to the phone book, complete the
following steps:
a. Click the Add button.
The Edit Phone Book Entry dialog box appears.
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Figure 8. Edit Phone Book Entry Dialog Box

b. Enter appropriate information in the Name, Phone Number, and Pager Delay
text boxes.

✏ If a prefix, such as the number 9, must be dialed first to get an outside line from your hone

system, include it in the Phone Number text box—even if you have already set up the prefix for
an outside line in the Telephony control panel.

c. Click the OK button.
The new phone book entry appears in the Edit Phone Book dialog box, listed
by name.
3. To make changes to any phone book entry, select the entry in the list on the Edit
Phone Book dialog box, then click the Edit button.
The Edit Phone Book Entry dialog box appears. Make any needed changes in the
text boxes, then click the OK button.
4. To delete an entry, select the entry in the list, then click the Delete button.
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5. When you are finished making changes to your phone book, click the OK button
on the Edit Phone Book dialog box.

Creating a Code Book
A code book in Remote Notification is a list of codes that the utility can send to pager
numbers. A code is a string of numbers. You give each code a name in the code book
for your reference, but only the numbers are sent to the pager.

✏ Some number sequences will not work with some pagers; you should manually test all codes
before using them in a code book.

Choose codes that are easy to recognize and make sure you communicate their
meanings to the recipients before using. The following list gives some sample codes
you might use:
Code Name

Code

Alarm

911

Warm-up Stage

1

Build Stage

11

Cool-down Stage

111

Build Complete

1111

You create a code book in the same way that you create a phone book. Select Edit→
Code Book, then continue with step 2 of the procedure in the preceding section. Read
all references to “Phone Book” as “Code Book.”

Creating Pager Lists
You can create a pager list for each event type. This list defines the pager numbers
that will be dialed if an event of that type occurs. To create a pager list:
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1. Double-click a cell in the Pager column of the Remote Notification window.

Double-click
this cell to
display the
Alarm
Paging List

Figure 9. Displaying the Paging List

The Paging List dialog box appears.
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Select a name
from the Phone
Book list

Then click the
right arrow button
to move the name
to the To be paged
list

17

Names in list are
displayed next to
the code that will
be sent for that
name
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To change the
assigned code for a
name, select the
name in the To be
paged list

Then select
a code for
the name

Figure 10. Sample Paging List Dialog Box

✏ You can also display the list by selecting the cell and then pressing the right trackball button, or
by selecting the cell and selecting Edit→ Pager List.

2. Add names and select a code for each name.
a. To add names to the To be paged list, select an entry from the Phone Book list
and click

. Repeat until all the people you want to page are on the list.

b. To select codes, first select a name in the To be paged list, then select a code in
the Select/Change Code list.
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Each name in the To be paged list can have one code that will be sent to its
pager when the appropriate event occurs.
3. If desired, click the Send Test Page button.
4. Click the OK button.

Setting Up E-Mail Notification
The Remote Notification utility can send e-mail to a different list of recipients for each
event type. The e-mail message that the utility sends contains the type of event, the
name of the computer sending the message, the text of the message, and a time
stamp. For example:
Alarm from DTM17
The PLC has stopped executing
Monday, Apr 15 09:10:07 1998
To use e-mail notification, you must:
1. Set up e-mail.
2. Create an address book.
3. Create mailing lists.
The sections that follow describe each of these steps in detail.

Setting Up E-Mail
To set up e-mail, select Edit→ Mail Setup. The Mail Setup dialog box appears. Enter
appropriate values in the two text boxes.

Software Utilities Guide

19

Setting Up Remote Notification

Figure 11. Mail Setup Dialog Box

Mail Server is the domain name of your mail server.
“From” Address is the address that will appear in the From header on the e-mail sent
by the Remote Notification utility. This can be any text string and does not have to be
a valid e-mail address. If it is not a valid e-mail address, recipients will not be able to
reply to e-mails sent by the utility.

✏ You may want to enter the address of a system administrator or SLS system technician so that
replies go to someone equipped to handle them, or you may want to enter a nonexistent
address so that no replies are possible.

Creating an Address Book
An address book is a list of addresses to which the Remote Notification utility can
send e-mail. It works much like the Phone Book and the Code Book that you create to
use with pagers. To create an address book for your company:
1. Select Edit→ Address Book.
The Edit Address Book dialog box appears.
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Click the Add button to
display a dialog box
where you can add
names and e-mail
addresses

Select a name, then
click the Edit button to
change a name or email address

Figure 12. Edit Address Book Dialog Box

2. For each e-mail address you want to add to the book, complete the following
steps:
a. Click the Add button.
A secondary Edit Address Book dialog box appears.
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Enter the name
that will appear
in the address
book list

Enter the
actual e-mail
address
Figure 13. Secondary Edit Address Book Dialog Box

b. Enter appropriate information in the Display Name and Email Address text
boxes.
c. Click the OK button.
The new address book entry appears in the Edit Address Book dialog box,
listed by name.
3. To make changes to any address book entry, select the entry in the list on the Edit
Address Book dialog box, then click the Edit button.
The Edit Address Book Entry dialog box appears. Make any needed changes in
the text boxes, then click the OK button.
4. To delete an entry, select the entry in the list, then click the Delete button.
5. When you are finished making changes to your address book, click the OK button
on the Edit Address Book dialog box.
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Creating Mailing Lists
You can create a different mailing list for each event type. This list defines the e-mail
addresses to which mail will be sent if an event of that type occurs. To create a
mailing list:
1. Double-click a cell in the Mail column of the Remote Notification window.

Double-click
this cell to
display the
Alarm Mailing
List

Figure 14. Displaying the Mailing List

The Mailing List dialog box appears.
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Select
a name
Click
button

Figure 15. Sample Mailing List Dialog Box

✏ You can also display the list by selecting the cell and then pressing the right trackball button, or
by selecting the cell and selecting Edit→ Mailing List.

2. Select a name in the Address Book list and click

to move it to the To list.

3. Repeat step 2 until all desired names are in the To list.
4. If desired, click the Send Test Message button.
5. Click the OK button.

Setting Up Programs
You can have the Remote Notification utility launch programs or issue commands
when specific types of events occur.
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To use these features, you must:
1. Create a program book.
2. Create program lists.
The sections that follow describe each of these steps in detail.

Creating a Program Book
A program book is a list of programs and/or system commands that you can have the
Remote Notification utility launch. It works much like the Phone Book, the Code Book,
and the Address Book. (Programs and system commands are treated the same by
the Remote Notification utility.)
To create a program book for your company:
1. Select Edit→ Program Book.
The Edit Program Book dialog box appears.
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Click the Add button to
display a dialog box where
you can add program
names and commands

Select a name,
then click the
Edit button to
change a name
or command

Figure 16. Edit Program Book Dialog Box

2. For each program you want to add to the book, complete the following steps:
a. Click the Add button.
A secondary Edit Program Book dialog box appears.
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Enter name
to display in
program list
Enter command
line to run when
event occurs
Figure 17. Secondary Edit Program Book Dialog Box

b. Enter appropriate information in the Display Name and Command Line text
boxes.
c. Click the OK button.
The new program book entry appears in the Edit Program Book dialog box,
listed by name.
3. To make changes to any program book entry, select the entry in the list on the Edit
Program Book dialog box, then click the Edit button.
The Edit Program Book Entry dialog box appears. Make any needed changes in
the text boxes, then click the OK button.
4. To delete an entry, select the entry in the list, then click the Delete button.
5. When you are finished making changes to your program book, click the OK button
on the Edit Program Book dialog box.

Creating Program Lists
You can create a different program list for each event type. This list defines the
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programs that will be launched if an event of that type occurs. To create a program
list:
1. Double-click a cell in the Run Program column of the Remote Notification window.

Double-click this
cell to display
the Alarm
Program List

Figure 18. Displaying the Program List

The Program List dialog box appears.
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Select a program
from the list
Click this button
to move the
program to the
Run list

Figure 19. Sample Program List Dialog Box

✏ You can also display the list by selecting the cell and then pressing the right trackball button, or
by selecting the cell and selecting Edit→ Program List.

2. Select a name in the Program Book list and click

to move it to the Run list.

3. Repeat step 2 until all desired names are in the To list.
4. Click the OK button.

Setting Up Z-Height Triggers
You can use Z-height triggers to select points in a particular build at which you want
specific consequences to occur. To set up Z-height triggers:
1. Select Edit→ Z Height Triggers.
The Edit Z Height Triggers dialog box appears.
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Absolute Z
heights, measured
from beginning of
Warm-up stage

Type a number
in the text box
Click the
Add button

Figure 20. Edit Z Height Triggers Dialog Box

2. Type a number in the New Z Height text box and click the Add button.
Each Z height that you enter will trigger a Z Heights Reached event, and produce
the consequences you have selected for that type of event.
3. Repeat step 2 until you have entered all desired Z heights.
4. Click the OK button.

Chapter 3
Remote Status
The Remote Status utility allows you to check the status of a build or view
temperatures and parameters for the SLS system via a dial-up connection or through
a computer connected to your SLS system computer across a network.
This section includes the following topics:
■ Features of Remote Status
■ Connecting and Starting the Utility
■

Installing the Utility on a Client
System

■

Using the Remote Status Utility
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Features of Remote Status
The Remote Status utility’s window looks similar to the standard SLS system
software main window. It connects to a host system (a system connected to an SLS
system and running the SLS system software) and displays a view-only version of the
host’s window on your client system (one connected to the host via a network, and
running the Remote Status utility).
The following figure shows the Remote Status application after you have connected
to a host system that is currently building parts:
You can distinguish this window from the
ordinary main window by the words
Remote Status in the title bar.

Track important
build data with the
Build Parts window

Messages
generated after you
connect to the host

Display Status
window to check
machine details
Figure 21. Remote Status Application When Connected

✏ If the host system is in Manual Operations mode, the application displays the Manual
Operations dialog boxes as soon as they are displayed on the host.
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Installing the Utility on a Client System
✏ You can install the Remote Status utility on any Windows 95, 98, NT, or 2000 system
connected to your SLS system via a network.

✏ 3D Systems believes that the Remote Status utility will work on a Windows 98 system;
however, this configuration has not been tested.

To install Remote Status, perform a standard SLS system software installation as
described in “Installing or Uninstalling the Software” in Chapter 3 of your Reference
Guide.

Changing Your Font Setting
If dialog boxes displayed in the Remote Status utility look unusual to you, your
system’s display font setting may be set to Small Fonts. The SLS system software
interface is designed to use the Large Fonts setting. To correct this situation:
1. Click your right trackball button on the background of your desktop.
A popup menu appears.
2. Select Properties from the popup menu.
The Display Properties dialog box appears.
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Settings tab

Font Size setting

Figure 22. Display Properties Dialog Box

3. Select the Settings tab.
4. Select the Large Fonts setting.
5. Click the Apply button.
You will need to restart your computer system before the new settings will take
effect.
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Connecting and Starting the Utility
Before you can start the Remote Status utility, you must be connected to the host
computer through a network or through a dial-up connection. If you plan to use a
dial-up connection, perform the dial-up and connect to your normal server before
you run the utility.
To start the Remote Status utility, click on the Remote Status menu option. You can
find this option in your Windows Start menu, on the DTM submenu.
The Remote Status window and the Connection dialog box appear:
You can click here to
display a list of previouslyused hosts
Select a
Host
name or
enter an
IP
address

Then click the
Connect button

Figure 23. Connection Dialog Box

Select a host name from the list in the Host name box (click the down arrow to see a
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list) or enter the IP address of the host system. Then click the Connect button.

✏ Use the default Socket Port number unless instructed to change it by 3D Systems.
After you click the Connect button, the system attempts to make a connection and if
successful, displays the Remote Status window.

Managing Host Information
You can store host information with the Connection dialog box so that you do not
have to memorize IP addresses. To store a host IP address, start the utility to display
the Connection dialog box. Click the New button and enter a host name in the Host
name box. Enter the IP address in the IP address text box. Finally, click the Save
button.
Use the Delete button to remove a host name from the list.
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Using the Remote Status Utility
You can use the Remote Status utility in the following ways:
■ To track a build
■

To check parameters in a Status window

Tracking a Build with Remote Status
To track a build on a host system, click
after you launch the Remote Status utility.
If the host system is building parts, the Build Parts window appears in your Remote
Status window. This window is a duplicate of the host system’s Build Parts window. If
the host system is not building parts, the application tells you that.
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Current build stage

Current temperatures
Figure 24. Build Parts Window in Remote Status Utility

If the host system is not currently running a build when you click
, the system
displays the message SinterStation is not currently building.

✏ The Build Viewer window is not available from the Remote Status utility.
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Viewing a Status Window with Remote Status
Status windows in the Remote Status utility operate just as they do in the SLS system
software. To open a Status window, select Machine→Status from the main menu or
click
. A Status window appears. For more information on Status windows, see
Chapter 5, “Using Status Windows” in your Reference Guide.
Select a category
on the left

The system
displays an
appropriate list
of messages on
the right

Figure 25. Status Window

Viewing Manual Operations
If Manual Operations dialog boxes are being used on the host system while you are
connected to it via the Remote Status utility, the dialog boxes will be mirrored in your
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Remote Status window. You can view the values and settings in the dialog boxes, but
you cannot activate any of the functions from the Remote Status utility.

Message List Window
The message list window displays messages generated during the time that your
client system has been connected to the host. Messages generated before you
connected cannot be displayed.

Chapter 4
Gettimes
The Gettimes utility runs on the SLS system computer. It creates a brief report from
the detailed information recorded in the states.blog file. It reports the times required
for adding a powder layer, loading the scanner, sintering a layer, and slicing a layer, as
well as total stage times for the warm-up, build and cool-down stages.
The Gettimes utility operates by reading the states.blog (in the c:\dtm\logs directory)
file and outputting its report to a file named time.data.
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Running Gettimes
You should start the Gettimes utility from an MS-DOS Command Prompt window
within the Windows environment.
1. To display an MS-DOS Command Prompt window, display the Start menu. Look
for the
option and select it.
An MS-DOS Command Prompt window appears.
2. Change to the c:\dtm\bin directory.
Your prompt should show you the current directory.
Type cd c:\dtm\bin and press Enter.
3. In the window, type gettimes and press Enter.
The system displays the following message:
Get Build Times Version x7.0

Command-line Options
There are three command-line options available with Gettimes. To use these options,
you type additional information after the command name in the MS-DOS Command
Prompt window.

✏ You can use any of these options in combination and in any order; type a space between each
option.

-i
The -i option is used to change the name of the input file. To use this option, type the
filename after the -i with no intervening spaces. For example, to cause the Gettimes
utility to use a file named OurMachineState.blog as input instead of the default
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states.blog, type the following command:
gettimes -iOurMachineState.blog
If the new input file is not in the current directory, you must give the full pathname.

-o
The -o option is used to change the name of the output file. As with -i, type the
filename after the -o with no intervening spaces. For example, to send the output to a
file named MyTimes instead of the default time.data, type the following command:
gettimes -oMyTimes

-f
Using the -f option causes Gettimes to include time values for each individual action,
such as adding a powder layer or loading the scanner, rather than the default method
of printing a summary of the total time spent in these actions.
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Sample Output
The following text shows sample output from running Gettimes:
Start inert, TIME = Mon Nov 9 11:21:07 1998
Inert reached, TIME = Mon Nov 9 11:31:28 1998
Time to inert = 0:00:10:21
New stage: Build setup, TIME = Mon Nov 9 14:05:27 1998
Start build: /usr2/sls2k/build/cpCallaway1.ja, TIME = Mon Nov
9 14:05:37 1998
Start inert, TIME = Mon Nov 9 14:05:42 1998
Inert reached, TIME = Mon Nov 9 14:05:49 1998
Time to inert = 0:00:00:07
Time in stage = 0:00:00:29
New stage: Warmup, TIME = Mon Nov 9 14:05:56 1998
Time in stage = 0:02:13:56
New stage: Build, TIME = Mon Nov 9 16:19:52 1998
Time in stage = 0:00:08:17
End of build stage:
Total slice time = 0:00:00:26
Total time waiting on the slicer = 0:00:00:00
Total add layer time = 0:00:02:10
Scanner load time overlapped with sintering/add powder
layer = 0:00:01:03
Scanner load time not overlapped with sintering/add
powder layer = 0:00:00:00
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Total sinter time = 0:00:06:00
Total wait for temperature time = 0:00:00:00
Total paused time = 0:00:00:00
End of build, TIME = Mon Nov 9 16:28:09 1998
Total build time = 0:02:22:32
New stage: Build setup, TIME = Mon Nov 9 16:28:13 1998
Start build: /usr2/sls2k/build/cpCallaway2.ja, TIME = Mon Nov
9 16:28:22 1998
Start inert, TIME = Mon Nov 9 16:28:25 1998
Inert reached, TIME = Mon Nov 9 16:28:32 1998
Time to inert = 0:00:00:07
Time in stage = 0:00:00:35
New stage: Build, TIME = Mon Nov 9 16:28:48 1998
Time in stage = 0:15:04:32
End of build stage:
Total slice time = 0:00:24:21
Total time waiting on the slicer = 0:00:00:00
Total add layer time = 0:03:57:49
Scanner load time overlapped with sintering/add powder
layer = 0:03:54:41
Scanner load time not overlapped with sintering/add
powder layer = 0:00:00:11
Total sinter time = 0:11:05:28
Total wait for temperature time = 0:00:00:46
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Total paused time = 0:00:00:00
New stage: Cooldown, TIME = Tue Nov 10 07:33:20 1998
Time in stage = 0:05:02:31
End of build, TIME = Tue Nov 10 12:35:51 1998
Total build time = 0:20:07:29

Chapter 5
Build Report
The Build Report utility extracts build information from SLS system log files and build
packets. The files produced by the utility can be imported into a spreadsheet
application for further manipulation.

✏ You must have SLS system log files and build packets available to use with the Build Report

utility. If you intend to create reports, make sure you do not delete the log files when you finish
a session with the SLS system software.

This section covers the following topics:
■ Generating Reports

■

Using Reports

Software Utilities Guide

47

Generating Reports

Generating Reports
To generate a custom report:
1. Start the Build Report utility.
You can start the utility by clicking a button on the summary dialog box that
appears at the end of a build, or from the Start menu. From the Windows Start
menu, select Start→ Programs→ SLS System→ Build Report. The SLS Build
Report utility window appears.
Select a build
packet (click the
arrow to display
a list of all build
packets in the
current log file)
Information
about the
selected build
packet
Figure 26. Build Report Utility Window

2. Display the Preferences dialog box by selecting Edit→ Preferences.
3. Select the information you want in your report in the Preferences dialog box.
See Figure 27., “Preferences Dialog Box,” on page 49.
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The Preferences dialog box has three tabs. Click on a tab to change the options
that are displayed. Each option has a check box. By default, most of the options
are already checked. Click on a check box to check or uncheck that option. The
system remembers your option choices the next time your run the utility, so if you
repeatedly run the same kinds of reports, you need only select your options once.
The available options include build parameters, part parameters, and build times.
See Figure 27 for more information on build times.
When all the options in all three tabs are set the way you want, click the OK button
to return to the SLS Build Report utility window.
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Preferences
dialog box
Click on tabs to
select a set of
options
Click on check
boxes to turn
options on or off
(checked
parameters are
included in reports)

Build Times
options
Select either Time
Summaries or
Detailed Times
If you select
Detailed Times,
select which of the
listed options you
want to appear in
your report

Figure 27. Preferences Dialog Box

Generating Reports
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4. Select a log file if needed.
The application automatically loads the log file in the c:\dtm\logs directory, if one
exists. If you want to use a different log file, select File→ Select log file and use the
Open dialog box to locate the file.
5. Save your report.
Select File→ Save build data. The Output Options dialog box appears.
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Select an output directory
by typing in the text box or
clicking the Browse button
Select the delimiter
(separator) for fields in
the report
Select whether you want
the report to include all of
the build packets or only
some of them
Click the
OK button
to save
your report
to the
output
directory

If you chose the Output
selected packets option,
select packets in this list.
For each packet you
select, a separate report
file is generated.
Figure 28. Output Options Dialog Box

6. Select the output options you want, as shown in Figure 28.
7. Click the OK button.
For each build selected, a file appears in the designated output directory (the default
directory is \dtm\logs). Each output file’s name uses the format
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buildpacketMMDDTTTT.rpt, where
buildpacket is the build packet file name minus the .bpf extension
MM is the number of the month
DD the day
TTTT the time when the build started.
For example, a report from a build packet named newmold.bpf built on February 2 at
11:02 a.m. would have the filename newmold02021102.rpt.

✏ If you change your preferences and save a report again without changing the output location,
the new report will overwrite the old one.
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The reports generated by the Build Report utility are text files with fields separated by
either commas or tabs, depending on the delimiter you chose in the Output Options
dialog box. These reports are designed to be imported into a spreadsheet or
database application. You can use these reports to record the part parameters for
each part in a build for later reference, or to track build and part parameters over
time. This data can be used to improve part accuracy or to keep track of optimum
parameters for builds. Figure 29 shows the basic format of a report generated by the
utility.

✏ Build Report outputs all measurements in inches, because all values in the states.blog file are

stored in inches. You can convert values to millimeters in your spreadsheet program if desired.
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Summary Build Report:

General build
information

Build started: 08/24/99 17:01:02

Table of part
parameters

Build ended: 08/24/99 17:12:10

Build packet:
C:\dtm\build\1bc_verified.bpf

Table of
rotation/scale
factors

Material: DuraForm Polyamide

Platform: SLS2500

All distance units are in inches

Part names:

bc1.stl_
1

bc1.stl_
2

Zheight

Value

Zheight

Fill Jump Delay

0

500

0

Fill Jump Speed

0

339.08

0

Fill Laser Off

0

1500

0

Profiled part parameters

Build
parameters
by stage
Value

Build500
heights

339.08
1500

Build times
Fill Laser On

0

1124

0

1124

Fill Scan Delay

0

36

0

36

Figure 29. Report Format

Chapter 6
Scale-Offset II and DTMRuntracker
Workbooks
This section describes the Scale-Offset II and DTMRuntracker workbooks. These are
Microsoft Excel workbooks you can use to generate scale and offset values and track
information about builds or parts over time.

✏ You can now purchase scale and offset calculation tools from 3D Systems that replace and
improve on the functions provided by these workbooks. See the Scale Calculation Tools
section of your Build Setup Help.

This section covers the following topics:
■ Minimum System Requirements

■

Setting Up the Workbooks

■

Uses for the Scale-Offset II Workbook

■

How to Use the Workbooks

■

Uses for the DTMRuntracker
Workbook
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Minimum System Requirements

Minimum System Requirements
The workbooks require a Windows computer system with Microsoft Excel installed
(version 97 or later). 3D Systems recommends a system with a minimum of 128 MB
of RAM and a 200 MHz or faster Pentium processor.
The system you use to run the workbooks does not need to be same one you use to
run the SLS system.

Solver Add-In
Before you can use these workbooks, you must have installed the Solver add-in. This
is a file that adds capabilities to Excel. It is not included in the default Excel
installation. See the documentation that came with your copy of Excel or the on-line
help for instructions on installing the Solver add-in.
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Uses for the Scale-Offset II Workbook
The Scale-Offset II workbook replaces previous methods for calculating scale and
offset values. It allows you to use any part as a scale part; you can select a scale part
based on the materials and geometries you are building. To scale a specific geometry,
you can use the actual part—building it once, measuring it, and then generating scale
and offset values to apply to future builds.

✏ You do not have to build an initial part without using scale and offset values in order to use the
worksheet. The worksheet can handle parts that were built with constant scale and offset. If
you want to use higher-order scale values, use the Opti-Scale™ scale calculation tools, an
optional module available for the Build Setup application.
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Uses for the DTMRuntracker Workbook
The DTMRuntracker workbook takes data from the Scale/Offset workbook and tracks
changes over time. Some uses for this data include:
■ Monitoring day-to-day machine variability
■

Measuring scale and offset at predetermined intervals for a wide variety of
geometries

■

Fine-tuning parameters when repeatedly building the same geometries
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Setting Up the Workbooks
You can find the two workbooks on the SLS system computer or on the SLS system
software CD that came with your system. Use the latest release of the SLS system
software.
They are .xls files found in the geometry\Samples\scale directory. To set up the
workbooks, copy them onto the hard-disk drive of the system you want to use them
on, or onto a network drive. There are two versions of the Scale-Offset II workbook,
one for Windows NT and 2000 (ScaleOffset II 2000.xls), and one for Windows XP
(ScaleOffset II XP.xls).
You must copy and rename the workbooks before you can use them. You may want
to name the copies after the parts that you are measuring or the machines you are
tracking.

✏ When you open one of these workbooks, Excel may display a message indicating that the
workbook contains macros and offering to disable them. Be sure to enable macros; the
workbooks require them.
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How to Use the Workbooks
The following procedures outline how to use the workbooks. The first worksheet in
each workbook contains detailed instructions for using the workbook.
To use the Scale-Offset II workbook for calculating scale and offset values:
1. Build a part and measure it.
The workbook calculates scale and offset values separately for each axis. For each
axis that you want to scale, you will need at least three data points; 3D Systems
recommends measuring at least five points.
You can use any part; see your Material Process Release Notes for
recommendations.
2. Enter the nominal and measured dimensions into a copy of the Scale-Offset II
workbook. Use the Data worksheet within the workbook.

✏ The original Scale-Offset II workbook is a read-only file; you must make a copy using the
operating system or Excel’s Save As feature before you can save changes.

✏ You can use any units with the Scale-Offset II workbook, as long as you are consistent. If you

enter values in inches, you will get inch values out; if you enter values in millimeters, you will
get millimeter values out. However, you must convert the Tolerance value from the default
(0.002 inches) to an appropriate value for the unit you are using; for millimeters, change the X,
Y, and Z tolerance to 0.051.

3. Calculate the scale and offset values.
To find the scale and offset values for each axis, click the Calculate X Values,
Calculate Y Values, and Calculate Z Values buttons in the Data worksheet.
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Figure 30. Scale/Offset II Workbook: Data Worksheet

To use the DTMRuntracker workbook to track scale and offset values:
1. Upload data from a copy of the Scale/Offset II workbook to a copy of the
DTMRuntracker workbook.

✏ The copy of the DTMRuntracker workbook that you plan to use must be closed when you
upload data to it.

In the Scale/Offset II workbook’s Data worksheet, click the Upload X data to SPC,
Upload Y data to SPC, and Upload Z data to SPC buttons in the Data worksheet.

✏ You will have to scroll to the right in the Data worksheet to see the Upload buttons.
2. Open the copy of the DTMRuntracker workbook.
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3. Verify your data, and delete any redundant data.
4. In each of the Plot worksheets within the DTMRuntracker workbook, click the
Update Plots button.
5. If desired, perform additional correlation as described in the DTMRuntracker
workbook.
A worksheet within the workbook, Correlation Data, is devoted to correlation
analysis of variables and user-defined variables.

Figure 31. DTMRuntracker Workbook

Chapter 7
STL Optimization Utility
This section describes the STL Optimization Utility, an application that makes STL
files load and display more quickly in the Build Setup application. It includes the
following topics:
■ Why You Should Optimize Files
■ How STL File Optimization Works
■

Using the STL Optimization Utility
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Why You Should Optimize Files

Why You Should Optimize Files
Optimized files render and load up to 10 times faster than unoptimized files, and they
remain valid STL files, editable by any application that accepts STL files

✏ If you edit an STL file in any application other than Build Setup, you should re-optimize it
afterward.

✏ If you optimize an STL file after using the Dimension Tool to establish nominal dimensions for
use with the Scale and Offset Calculation Wizard, the nominal dimensions will no longer be
valid and must be selected again. See your Build Setup Help for information on using these
Scale Calculation Tools.

STL files are the input files used in the SLS process; STL files are created by
computer-aided design (CAD) software.
When you add an STL file to a build, the Build Setup application checks to see if it has
been optimized; if it has not, the application asks if you want to optimize it. In most
cases, you will not need to use the STL Optimization Utility as a separate application.
However, it can be useful if you want to optimize large numbers of files at once.
If you want to know whether a particular file has been optimized, add the STL file to a
build in the Build Setup application, then display the Information View and look at the
Part Info tab. If it is optimized, the file’s File Type will be listed as Optimized Binary.
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Using the STL Optimization Utility
To use the utility to optimize one or more files:
STL Optimization button

Figure 32. STL Optimization Button on the Build Setup Toolbar

1. Start the utility from within the Build Setup application by selecting Tools→
Optimize STL Files, by clicking the appropriate icon on the toolbar, or from the
Windows Start menu by clicking Start→ Programs→SLS System→ STL
Optimization.
The 3D Systems STL File Optimization Utility window appears.
2. Select the STL files you want to optimize.
You can select any combination of files and/or directories.
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File/directory list
Select drive and
directory

Select file or files
When you click
this button, the
utility adds the
currentlyselected file or
directory to the
list on the right (if
no file is
selected, a
directory is
added)
To remove an
item from the
file/directory list,
select it and click
this button

Click the Next button
when you have selected
all the files you want to
optimize
Figure 33. Selecting Files/Directories to Optimize

3. Click the Next button.
An options window appears.
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Click here to
enable removal
of details that
cannot be
reproduced in
the SLS system

Select
an
option

Click the
Do It
button; a
progress
log
appears
in the
large text
box

This area is blank for the first
option and displays an
appropriate field when you
select the second or third
option

Figure 34. STL Optimization Utility Options Window

4. Select an option.
If you select the Append Suffix option, enter a suffix or accept the default “opt”
suffix.
If you select the Put On Different Directory option, select an output directory.
5. Select or deselect the Do Not Do if Already Optimized check box.
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6. If you want the system to compress your STL files, select the Remove Small
Facets check box.

✏ Since this option modifies your STL file, the system disables the Overwrite Original Files
option if you select Remove Small Facets.

You can select a Lower Threshold setting to indicate when facets are too small to
be useful.
7. Click the Do It button.
The utility processes the files and displays a progress log in the large text box on
the window. The Do It button changes to a Cancel button while the utility is
processing the files, then to a Close button when done.
8. To process additional files, click the Previous button to return to the file/directory
selection window. To quit, click the Close button.
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How STL File Optimization Works
Facets in most STL files are listed randomly. The STL Optimization Utility sorts the
facets into an order that can be used by the Build Setup application to speed loading
and display. It also removes unnecessary facets (facets that provide levels of details
that cannot be reproduced in the SLS system) and combines some facets to reduce
the file size and load times.

✏ Although it may take several minutes to optimize a large STL file, the task only needs to be
performed once. Also, you can optimize whole directories of STL files as a batch process,
overnight or during other available down time.

Chapter 8
RealMonitor and RealMonitor Viewer
This section describes RealMonitor and RealMonitor Viewer, two related applications
which allow you to collect and review data about your system. These applications
replace the Remote Diagnostic application, handling all of its functions and providing
additional ones.
With RealMonitor, you can choose when to log system data, and see live graphs and
comparisons of system parameters while your SLS system operates. After a build,
use RealMonitor Viewer to examine and analyze the data logged by RealMonitor. This
section includes the following topics:
■ Licenses for the Applications
■ Setting the Y Scale Range
■

Starting the Applications

■

Printing Plots

■

Logging Data with RealMonitor

■

Preferences

■

Comparing Parameters in
Either Application

■

Reviewing Logged Data with
Real Monitor Viewer

■

Zooming in X and Y
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Licenses for the Applications
RealMonitor and RealMonitor Viewer are licensed applications. You need a license to
make full use of either application, however, you can log diagnostic data about your
system with RealMonitor before you install a license. You cannot view the data
without a license, but a 3D Systems technician can analyze it, and you can send the
logged data to 3D Systems for help in resolving a problem.
Only one license is required for these paired applications; installing a license for
either application provides the same level of license for the other application.

Installing a License
If you launch RealMonitor Viewer without a valid license installed, the licensing dialog
box appears. Or you can click the Enable button in RealMonitor to display it. You can
also upgrade your license at any time by clicking the Enable button in either
application.

Click to
enable a
license

Figure 35. RealMonitor, Before Enabling a License
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The application displays a dialog box with your computer’s identification code.
Contact 3D Systems as directed in the dialog box and provide your code.
3D Systems Customer Support will provide you with a license password specific to
your system. Enter the license password in the license dialog box.

License Types
Several types of licenses are available for the RealMonitor and RealMonitor Viewer
applications.
■ The Default license, which comes with the software, allows your system to log
data but not view it. 3D Systems personnel can still retrieve and analyze data
logged in this manner.
■

A Basic license allows you to log data and view it in real time, as well as view
saved monitoring data.

■

An Advanced license has the capabilities of the Basic license, and also allows you
to export data to a delimited file, as well as use a dynamic-link library (DLL) to
access the logged data in real time from a custom application program.

Replacing Licenses
The license password will persist after an upgrade of the SLS system software.
However, you will need to contact 3D Systems Customer Support to get a new
password if you do either of the following:
■ Reinstall your operating system
■

Change your network configuration; (for example, if you replace your network
card)
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Starting the Applications
RealMonitor cannot be started or stopped on its own; instead, it starts and stops
automatically with the Sinter application.
You can start RealMonitor Viewer by clicking the RealMonitor Viewer shortcut in the
SLS System folder on your Start menu. You can run RealMonitor Viewer while Sinter
and RealMonitor are running, and you can run multiple copies of RealMonitor Viewer.

Logging Data with RealMonitor
RealMonitor does not track your system all the time. Two boxes underneath the
RealMonitor toolbar offer options for starting and ending monitoring.
The application defaults to starting monitoring at the beginning of a build and ending
it when the build is over. It returns to these settings when you end a build or restart
the Sinter application, so that RealMonitor always monitors each new build unless
you specifically change its settings.
The other start options include:
■ Manual, which enables the Start button; click it when you want to start
monitoring.
■

Beginning of build stage

■

Beginning of cool down stage

■

Specified warm up height

■

Specified build height

Similar options exist for ending monitoring.
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Comparing Parameters in Either Application
The two diagnostic applications display similar graphs, allowing you to view and
compare machine parameters over time. For each parameter section, you can select
a parameter in the Plot Parameter list. The system graphs the parameter to the right.

✏ If you want to view more than two parameters with RealMonitor Viewer, you can launch an
additional copy of the application, load the same log file, but select different parameters to
view in it.

Parameter Graphs
Parameter graphs within the applications show a variety of data about a build.
Warm-up stage (pink)
Pause (grey)

Build states are color-coded; cooldown (blue) and
build preparation
(yellow) are not
shown

Build stage
(green)
Machine is
idle (white)

Event (change in build
parameter); see Events

Setpoint graphed in red alongside
the parameter value, shown in black

Figure 36. Sample Parameter Graph
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Events
RealMonitor tracks a number of events during a build. Events are marked with a
vertical line, and an abbreviation (above the line). The line and abbreviation are also
color coded. The following table shows the monitored events:
Abbreviation

Event

Description

PM

Pause Monitor

Monitoring was paused.

SR

Sample Rate

The sampling rate was changed by the user.

BP

Build
Parameter

A build parameter was manually adjusted.

PP

Part Parameter

A part parameter was manually adjusted.

BM

Build Mode

The build mode was manually adjusted

AD

Add/Delete
Parts

Parts were manually added or deleted

PC

Prime Cycle

A prime cycle was run.

NS

Next Stage

The system was manually directed to move to the
next stage of the build.

TM

Terminate

The build was manually terminated.

AL

Alarm

A system alarm occurred.

R1

Calibration on

The system began real-time calibration.

R0

Calibration off

The system stopped real-time calibration.

RA

Real-time
adjustment

A calibration adjustment occurred.
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Zooming in X and Y
In either application, you can change the
visible portion of either of the two graphs
displayed in the window by clicking the Zoom
X or Zoom Y buttons.
After clicking Zoom X or Zoom Y, use the left
and right mouse buttons to zoom in and out.
The zooming action is centered on the region of the graph where you click your
pointer.
Use the mouse wheel, if available, to scroll within the graph. If you place the mouse
inside the plot, the graph is scrolled on the X axis. Placing the mouse on the left side
of the plot allows you to scroll in the Y axis.
Click the Reset button to return to the original zoom settings.

Setting the Y Scale Range
Click the Y-Scale button to display a dialog box with fields for minimum and
maximum values of the Y axis for either graph.
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Printing Plots

Figure 37. Y Scale Dialog Box

Printing Plots
Click the Print button in either application to display a dialog box of printing options.
The system prints the two current graphs to the printer you select.

Preferences
The two applications have similar but separate preference options. Click the Pref
button in either application to display a preferences dialog box.
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Preferences

Figure 38. Preferences in RealMonitor/RealMonitor Viewer

In either application, you can use the preferences dialog box to:
■ Change the display unit (inches or millimeters)
■

Set data file limits for both RealMonitor data and States.blog data, in terms of
available disk space, number of data files used, and total data file size.

RealMonitor Options
Machine Name: This field determines the machine name that will be written to the
log file. The default value for this name is taken from the SLS system configuration
files; if this name does not reflect the name you use to identify your machine, edit the
field.
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Lag Time After End Event: Sets how long RealMonitor continues logging after a build
is complete.

RealMonitor Viewer Options
Average Data Points: When you display pinpoint data with RealMonitor Viewer, it
displays an average value for the point, created by averaging the point with as many
preceding points as are specified by this value. See Viewing Pinpoint Data for more
information.

Reviewing Logged Data with Real Monitor Viewer
Use RealMonitor Viewer to view log files (.rmt files) generated by RealMonitor from
past builds. RealMonitor Viewer has additional features for viewing data that are not
available in RealMonitor.

Loading a RealMonitor Log File
Click the Browse button to display a standard Windows file-opening dialog box, and
use it to open a RealMonitor log file to examine with RealMonitor Viewer. By default,
RealMonitor data files are stored in the \dtm\logs\RMData folder.

✏ Most of RealMonitor Viewer’s buttons remain inactive until you load a log file.
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Basic build
packet and
machine
information
for the
selected log
file

Figure 39. RealMonitor Viewer Window

Viewing Pinpoint Data
To get more specific information about a point on the RealMonitor Viewer graph,
hover your mouse pointer over the point, or click on the point:
■

When you pause your mouse pointer over a point on the plotted graph,
information about the data point appears in a pop up window, including its value
(y), time (x), stage height and set point, as well as an average value created by
averaging the current point with some number of preceding points (defined by
the Average Data Points preference option). If an event is associated with the data
point, the event description also appears.
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When you click on a point on the curve, green horizontal and vertical lines
pinpoint your location, and the application displays a popup window with
information about the selected point. When you have selected a point in this way,
you can move the selection forward or backward through the graph with the
arrow keys on your keyboard.

Displaying Build Properties
Click the Property button in RealMonitor Viewer to display a dialog box with
information about the build whose data you are viewing. Basic information such as
the platform, machine name, and material type is displayed at the top of the window,
with details such as build and part parameters displayed in tabs at the bottom.

Click tabs to display different
categories of information

Print the data or save it to a
file

Figure 40. Properties Dialog Box
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Exporting Data Files
If you have an Advanced license, you can export data when you are using
RealMonitor Viewer. Click the Export button to save data from the current file to a text
file.

Appendix A
Legal Notices
Copyright and Corporate Identity
© 2004 by 3D Systems, Inc. All rights reserved. Subject to change without notice.
This document is copyrighted and contains proprietary information that is the
property of 3D Systems, Inc. The licensed user, in the name of whom this document
is registered (the “Licensed User”) does not have the right to copy, reproduce, or
translate this document in any way or to any media without the prior written consent
of 3D Systems, Inc. No copies of the document may be sold or given to any person
or other entity.

Improvements
3D Systems may (but shall not be obligated to) make improvements to this document
from time to time. However, the Licensed User acknowledges that at any time after
the expiration of the date of issuance, 3D Systems may institute a periodic charge or
fee payable by the Licensed User in return for ongoing receipt of improvements. It is
the responsibility of the Licensed User to provide 3D Systems with current
information as to its name and address. The Licensed User also undertakes to notify
3D Systems promptly in the event that it considers any of the data contained in this
document to be incomplete or erroneous in any respect, in connection with Licensed
User's particular use or generally.

FCC Notice
This equipment has been tested and found to comply with the limits for a class A
digital device, pursuant to Part 15 of the FCC Rules. These limits are designed to
provide reasonable protection against harmful interference when the equipment is
operated in a commercial environment. This equipment generates, uses, and can
radiate radio frequency energy and, if not installed and used in accordance with the
instruction manual, may cause harmful interference to radio communications.
Operation of this equipment in a residential area is likely to cause harmful
interference in which case the user will be required to correct the interference at his
own expense.
Changes or modifications not expressly approved by 3D Systems could void your
authority to operate this equipment.
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Limitations of Warranty and Liability

Limitations of Warranty and Liability
This information is provided by 3D Systems for the convenience of its customers. It
is believed to be reliable, but NO REPRESENTATIONS, GUARANTEES OR
WARRANTIES OF ANY KIND ARE MADE AS TO ITS ACCURACY, FITNESS FOR A
PARTICULAR USE OR THE RESULTS TO BE OBTAINED THEREFROM. The
information is based in whole or in large part on laboratory work and does not
necessarily indicate performance in all conditions. Notwithstanding any information
provided by 3D Systems or its affiliates, the customer remains fully responsible for
determining which federal, state or local laws or regulations, or industry practices are
relevant to activities in which it engages, as well as assuring that those laws,
regulations or standards are complied with under actual operating conditions, and
3D Systems undertakes no responsibility in these areas.
IN NO EVENT WILL 3D Systems BE RESPONSIBLE FOR DAMAGES OF ANY
NATURE, INCLUDING SPECIAL OR CONSEQUENTIAL DAMAGES, RESULTING
FROM THE USE OF OR RELIANCE UPON THIS INFORMATION. THE CUSTOMER
ASSUMES ALL RISK RESULTING FROM THE USE OF THIS INFORMATION.
Customers use of the materials that follow is an acknowledgment of its agreement to
the foregoing. Any customer not wishing to be bound should return this material to
3D Systems. Nothing contained herein is to be considered as permission,
recommendation, nor as an inducement to practice any patented invention without
permission of the patent owner.

Trademarks and Registered Trademarks
SLS and Sinterstation are registered trademarks of 3D Systems, Inc. SLS, Vanguard,
HiQ, LaserForm, DuraForm, and Opti-Scale are trademarks of 3D Systems, Inc.
Other trademarks are the property of their respective owners.

Index
A

D

address book, creating 19

dialog boxes
Connection 34
Display Properties 33
Edit Address Book 20
Edit Phone Book 13
Edit Phone Book Entry 14
Edit Program Book 25
Edit Z Height Triggers 29
Mail Setup 19
Mailing List 23
Output Options 51
Pager Setup 11
Paging List 17
Preferences 49
Program List 28
Display Properties dialog box 33
Dtm menu 2
DTMRuntracker workbook
about 55
minimum requirements 56
setting up 59

B
Build Parts window, in Remote Status
utility 37
Build Report utility
about 46
generating reports 47
units used 53
using reports 53
Build Report Utility window 47
build, tracking with Remote Status 36

C
code book, creating 15
command-line options 41
Connection dialog box 34
consequences of events 5
custom reports 47

#
A
B
C
D
E
F
G
H
I
L
M
N
O
P
R
S
T
U
V
W
Z

Software Utilities Guide

E
Edit Address Book dialog box 20
Edit Phone Book dialog box 13
Edit Phone Book Entry dialog box 14
Edit Program Book dialog box 25
Edit Z Height Triggers dialog box 29
e-mail notification, setting up 18
e-mail, setting up 18
events, that can trigger notification 5
Excel, Solver add-in 56

G
Gettimes
command-line options 41
running 41
sample output 43
getting started 2

I
input file, changing name in Gettimes
41
introduction 1

M
mail server 19
Mail Setup dialog box 19
Mailing List dialog box 23
mailing lists, creating 22
Microsoft Excel workbooks 55

87

modem IP address 11

O
optimizing STL files 65
output file, changing name of in
Gettimes 42
Output Options dialog box 51

P
pager lists, creating 15
pager notification, setting up 8
Pager Setup dialog box 11
pager, setting up 11
Paging List dialog box 17
phone book, creating 13
Preferences dialog box 49
Prgram List dialog box 28
program book, creating 24
program lists, creating 26
programs, setting up 23

R
Remote Notification
consequences 5
creating
address book 19
code book 15
mailing lists 22
pager lists 15

#
A
B
C
D
E
F
G
H
I
L
M
N
O
P
R
S
T
U
V
W
Z

Software Utilities Guide

phone book 13
program book 24
program lists 26
events 5
introduction 3
printing settings from 7
setting up
e-mail 18
e-Mail notification 18
pager 11
pager notification 8
programs 23
Z-height triggers 28
settings files 5
starting 4
storing setup information 5
Remote Status
changing your font setting 32
installing on a client system 32
problems 32
starting 34
tracking a build 36
using 36
viewing a Status window 38
RemoteNotify window 4

S
Scale-Offset II workbook
about 55
minimum requirements 56

88

setting up 59
settings files 5
Socket Port text box 12
Solver add-in, for Excel 56
Start menu 2
starting the utilities 2
states.blog file 40, 42, 53
Status window 38
STL File Optimization Utility window
65, 66
STL files 63, 70
STL Optimization Utility 63, 70
storing setup information 5

T
tracking a build 36

V
viewing a Status window 38

W
windows
Build Parts 37
Build Report Utility 47
RemoteNotify 4
Status 38
STL File Optimization Utility 65, 66
workbooks 55

#
A
B
C
D
E
F
G
H
I
L
M
N
O
P
R
S
T
U
V
W
Z

Software Utilities Guide

Z
Z-height triggers, setting up 28

89

#
A
B
C
D
E
F
G
H
I
L
M
N
O
P
R
S
T
U
V
W
Z

